FW: [parisc-linux] cd-rom

Soto, Gene G. Gene.Soto@bakeroiltools.com
Thu, 30 Dec 1999 08:16:06 -0600

From:  Soto,  Gene G.
Sent:  Thursday, December 30, 1999 7:32 AM
To:  'John David Anglin'
Subject:  RE: [parisc-linux] cd-rom

I was able to mount it by resetting the switches (although I could swear I
tried them with the current configuration but on scsi id switch 3).

Your information is greatly appreciated.
	From:  John David Anglin [SMTP:dave@hiauly1.hia.nrc.ca]
	Sent:  Wednesday, December 29, 1999 11:05 AM
	To:  Gene.Soto@bakeroiltools.com
	Cc:  jb@sapin.irfu.se; <mailto:jb@sapin.irfu.se;>
parisc-linux@thepuffingroup.com <mailto:parisc-linux@thepuffingroup.com> 
	Subject:  Re: [parisc-linux] cd-rom

	> 	correction: it is a NEC MultiSpin 2Xe (CDR-74-1)
	> 	i have set the ID to 4.  I also tried it on 3 and it would
	> detect it.
	> 	it has 4 switches on the back and i have 1 & 2 set opposite
of what
	> is recommended
	> 	on the NEC webpage for installation on IBM or compatibles
	> the only way SAM
	> 	detected the device):
	> 	switch 1 is Factory Use Only(Normal OFF) (I have it ON)
	> 	switch 2 is Termination ON/OFF (I have it OFF)
	> 	switch 3 is SCSI2/ON SCSI1/OFF (I have it OFF)
	> 	switch 4 is Factory Use Only(Normal OFF) (I have it ON)

	Strange.  I have a NEC CD-ROM drive on my machine and I am pretty
	certain the switch settings are per the drive manual.  In general,
	If this is the last drive on the chain, termination should be on.
	SCSI2 should be OK.  You should be able to see the drive with
	diskinfo if you have the SCSI ID and driver major/minor set

	> 	is it possible to add something to pd_devinfo.tx that would
allow it
	> to mount?

	Yes.  However, this is only for sam.  You should be able to manually
	mount/umount the drive.  The busy error indicates that some process
	trying to open device file (possibly, because you have the device
	in /etc/checklist).

	> 	when I try adding the following entry to /etc/checklist:
	> 	/dev/dsk/c201d4s0 /cdrom cdfs defaults
	> 	i get the following message when i try to mount it:
	> 	/dev/dsk/c201d4s0: Device busy

	J. David Anglin                                  dave.anglin@nrc.ca
	National Research Council of Canada              (613) 990-0752
(FAX: 952-6605)

X-From-Line: hppa-linux@thepuffingroup.com  Thu Mar 11 17:55:14 1999
Return-Path: <hppa-linux@thepuffingroup.com>
Received: from merlin.pcj.primenet.com (pcj@merlin.pcj.primenet.com [])
	by merlin.pcj.primenet.com (8.8.7/8.8.7) with ESMTP id RAA14509
	for <pcj@merlin.pcj.primenet.com>; Thu, 11 Mar 1999 17:55:14 -0800
Resent-From: hppa-linux@thepuffingroup.com
Received: from pop.primenet.com
	by merlin.pcj.primenet.com (fetchmail-4.4.7 POP3)
	for <pcj/merlin.pcj.primenet.com> (single-drop); Thu, 11 Mar 1999 17:55:14 PST
Received: from smtp03.primenet.com (daemon@smtp01.primenet.com [])
	by primenet.com (8.8.8/8.8.5) with ESMTP id SAA19618
	for <pcj@smtp-local.primenet.com>; Thu, 11 Mar 1999 18:44:03 -0700 (MST)
Received: (from daemon@localhost)
	by smtp03.primenet.com (8.8.8/8.8.8) id SAA07402
	for <pcj@primenet.com>; Thu, 11 Mar 1999 18:44:01 -0700 (MST)
Received: from SOD.RES.CMU.EDU(
 via SMTP by smtp03.primenet.com, id smtpd007384; Thu Mar 11 18:43:58 1999
Received: (from listserv@localhost)
	by sod.res.cmu.edu (8.8.7/8.8.7) id UAA10433;
	Thu, 11 Mar 1999 20:43:59 -0500
Resent-Date: Thu, 11 Mar 1999 20:43:59 -0500
X-Authentication-Warning: sod.res.cmu.edu: listserv set sender to hppa-linux-request@thepuffingroup.com using -f
Delivered-To: thepuffi-hppa-linux@thepuffingroup.com
Date: Thu, 11 Mar 1999 17:43:42 -0800 (PST)
From: Kevin Vajk <kvajk@cup.hp.com>
To: hppa-linux@thepuffingroup.com
Subject: Re: [hppa-linux] Bootstrap #4 successful
Message-Id: <Pine.LNX.4.04.9903111741010.2848-100000@uxho0334.cup.hp.com>
Mime-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
Resent-Message-ID: <"YiYYA2.0.wY2.U57ws"@sod.res.cmu.edu>
Reply-To: hppa-linux@thepuffingroup.com
X-Mailing-List: <hppa-linux@thepuffingroup.com> archive/latest/173
X-Loop: hppa-linux@thepuffingroup.com
Precedence: list
Resent-Sender: hppa-linux-request@thepuffingroup.com
X-UIDL: ce7cec2dfee7646a4e7096b4f8f029f6
Lines: 54
Xref: merlin.pcj.primenet.com palinux:144

Another success booting from disk on an 816/E35.

- Kevin Vajk

Main Menu: Enter command or menu > boot 56/40.6
Interact with IPL (Y or N)?> y

Boot IO Dependent Code (IODC) revision 4

HARD Booted.


PARISC/Linux Bootstrap Version 0.2 (interactive)
By Jason Eckhardt
Built Thu Mar 11 16:01:50 CST 1999 by jason@sathanas

IPL_DEBUG: Page zero parameters:
  P0_IMM_max_mem:          134217728 (128 MB)
  P0_BOOTCPU_10msec:       640000 (64 MHz)
  P0_BOOTCPU_mem_free:     0x00008000
  P0_BOOTCPU_hpa:          0xFFFBE000
  P0_BOOTCPU_pdc:          0xF001F648
  P0_COUT_iodc_io:         0x00008000
  P0_CIN_iodc_io:          0x00008000
  P0_BOOTDEV_iodc_io:      0x00008410
  P0_COUT_class:           0x00000007
  P0_CIN_class:            0x00000007
  P0_BOOTDEV_class:        0x00000001
Reading parameters...done.
Size = 28672 bytes, entry = 0x00001000, location = 0x0001B000.
Loading kernel...done.
Transferring control to kernel.


VMLINUX 0.0: Dummy kernel image loaded and executing!

It is now safe to reboot.

To unsubscribe: send e-mail to hppa-linux-request@thepuffingroup.com with
`unsubscribe' as the subject.