[parisc-linux] palo-1.4 broken on 32bit ?

Grant Grundler grundler at parisc-linux.org
Tue May 4 14:11:22 MDT 2004

On Tue, May 04, 2004 at 09:36:28PM +0200, Helge Deller wrote:
> Hi all,
> after apt-get upgrading to palo_1.4_hppa.deb it seems, that palo-1.4 isn't able any longer to boot up a 32bit Linux kernel on a 32bit Machine.
> I've run several tests on a B180L, and only after downgrading to palo-1.3 I was able to boot again.
> Am I the only one seeing this problem ? 

No - I've been seeing it on the c3600 as well.
I haven't tried 64-bit kernels.
And downgrading iplboot to 1.3 also solves it for me too.

palo 1.3 deb is available here in case someone has upgraded:

thanks to paul bame for keeping those around.

> Anyone maybe has an idea what has been changed ?

nope...have to look at palo since it doesn't matter which
kernel I attempt to boot, it doesn't work.

Note that I tried to build palo v1.2 and that failed the same way.
So it's possibly a compiler issue with real-mode code.
(Not that the compiler knows the difference...)


More information about the parisc-linux mailing list