[parisc-linux] [hppa] problem using glibc2.3 with older 64-bit kernels

Randolph Chung Randolph Chung <tausq@debian.org>
Sun, 8 Dec 2002 22:08:33 -0800

This is a heads up for people running 64-bit hppa kernels with new glibc
(2.3.1). Make sure you have at least 2.4.19-pa17, otherwise fcntl() will
break with the new glibc and you won't be able to use e.g. apt.

This was needed to fix some problems with lfs on hppa. Unfortunately it
cannot be done in a completely backwards compatible manner.

32-bit kernels are not affected.

Randolph Chung
Debian GNU/Linux Developer, hppa/ia64 ports