linux grundler

Grant Grundler grundler@puffin.external.hp.com
Mon, 29 Jan 2001 14:49:24 -0700


CVSROOT:	/home/cvs/parisc
Module name:	linux
Changes by:	grundler	01/01/29 14:49:24

Modified files:
	arch/parisc/kernel: drivers.c inventory.c setup.c 
	include/asm-parisc: hardware.h pdc.h spinlock.h 

Log message:
Replace register_module() with a slightly more flexible scheme.
PAT PDC support wanted this.
Now use:

struct hp_device *dev = alloc_pa_dev((unsigned long) hpa);
if (dev) {
/* if needed, drop more stuff in dev */
(void) register_pa_dev(dev);
}

Current usage is to ignore the return value from register_pa_dev().
If someone cares, the return value is dev->managed.

Other stuff: removed trailing white space, misnamed proto's in pdc.h, and
tweaked volatile casts in spinlock.h to use declared type.